Accueil>Tutoriels Excel>Fonction SI Excel

Fonction SI Excel

La fonction Excel Si permet d’afficher une valeur ou d’effectuer un calcul selon plusieurs conditions.
Elle permet de traiter la problématique suivante : Si Question Alors Toto Sinon Tutu.

Toto et Tutu prennent la valeur que vous déterminez (référence à une cellule, donnée, formule).

La fonction SI EXCEL s’appelle « IF » en anglais.

Syntaxe de la fonction Excel SI

La syntaxe de la formule SI est :

= SI (Test_logique; Valeur_si_vrai; Valeur_si_faux)

La formule SI Excel a 3 arguments. Les arguments sont séparés par des points virgules.
La signification des arguments est la suivante :

  •  Test_logique : Réalisation d’un TEST dont le résultat est soit VRAI soit FAUX
  •  Valeur_si_vrai : valeur ou formule si le TEST renvoie la valeur VRAI (OUI)
  • Valeur_si_faux :  Valeur ou formule si le TEST renvoie la valeur FAUX (NON)

Comment utiliser la fonction SI Excel à partir un exemple ?

Pour illustrer cette fonction, l’exemple qui sera utilisé correspond à la problématique suivante : vous souhaitez tester les numéros de Sécurité sociale.

SI le numéro de Sécurité Social commence par 2 ALORS vous affichez l’information «Madame» SINON vous renvoyez «Monsieur».

L’objectif final est d’afficher les informations suivantes :

fonction-si-excel-SS-final

Pour arriver à ce résultat, nous allons décomposer les étapes.

Comment construire la fonction Excel SI avec l’assistant ?

Dans un premier temps, saisissez des 1 et des 2 dans différentes cellules de C3 à C7.
Positionnez-vous ensuite en D3 et tapez =si(
Vous cliquez ensuite sur le bouton Fx qui est à droite de la barre de formule.

fonction-si-assistant

En cliquant sur Fx vous ouvrez l’assistant qui permet de saisir les 3 paramètres de la fonction SI.

Test_logique, premier argument de la fonction SI Excel :

Le premier paramètre est le test logique : il s’agit d’un test ou d’une formule qui peut renvoyer 2 valeurs possibles : VRAI ou FAUX.
Il existe plusieurs moyens de renvoyer VRAI ou FAUX, nous détaillerons ensuite les tests possibles.
Dans le cas qui nous intéresse nous avions convenu de tester si nous avions la valeur 2 dans la cellule C3
Vous pouvez donc cliquer dans la cellule C3 puis écrire =2.

assistant-si-excel-un

Vous testez si la cellule est égale à 2 et vous voyez que l’assistant renvoie la valeur VRAI. En effet, sur la ligne du test dans l’assisant, à droite, vous pouvez visualiser le résultat du test conditionnel.

Valeur_si_vrai, second argument de la formule Excel SI :

Placez ensuite la souris dans la seconde case. Nous allons préciser le 2ème paramètre de la fonction SI, c’est-à-dire que nous allons définir ce que nous souhaitons qui se passe si le test logique est VRAI. Dans notre cas quand C3=2. Nous souhaitons afficher Madame alors il faut saisir « Madame » avec des guillemets. Pour préciser à Excel qu’il s’agit de texte, il faut toujours rajouter des guillemets.
Il s’agit de la valeur Alors de la question de départ :
SI le numéro de sécurité commence par 2 ALORS vous affichez l’information Madame SINON vous renvoyez Monsieur.

Valeur_si_faux : troisième argument de la fonction SI Excel :

Placez ensuite la souris dans la troisième case. Nous allons préciser le 3ème argument de la formule SI, c’est-à-dire que nous allons préciser ce que nous souhaitons qui se passe lorsque le test est FAUX . Dans notre cas quand C3 n’est pas égal à 2. Nous souhaitons afficher Monsieur alors il faut saisir « Monsieur » avec des guillemets.
Il s’agit de la valeur Sinon de la question de départ.

assistant-si-excel-deux

En cliquant sur OK, la fonction est validée.
=SI(C3=2;“Madame”;“Monsieur”)
Dans la fonction les différents éléments sont séparés par des points virgules.

Pour le 2ème et 3ème paramètre : diverses actions peuvent être réalisées :

Affichage d’un nombre :
Affichage d’un texte :
Affichage d’un résultat de calcul :
Affichage d’un contenu de cellule :
Aucun affichage :

saisir le nombre
saisir le texte entre guillemets
entrer la formule de calcul
montrer la cellule
taper “”

Quels tests logiques réalisés dans la fonction SI Excel ?

Le premier paramètre de la fonction est un élément qui renvoie une valeur VRAI ou FAUX.

Il existe de très nombreuses manières de faire des tests sous Excel.

Comparer la valeur d’une cellule par rapport à un standard.

Liste des opérateurs pour faire une comparaison dans une fonction SI Excel

est égal à =
est différent de <>
est supérieur à >
est supérieur ou égal à >=
est inférieur à <
est inférieur ou égal à <=

Il est possible de tester des valeurs numériques, du texte et des dates.
Quand vous tester du texte, veillez à utiliser des guillemets.

Toutes les fonctions Excel qui permettent de renvoyer VRAI ou FAUX comme résultat peuvent être utilisées pour le premier argument de la fonction SI.

Liste des fonctions Excel renvoyant VRAI ou FAUX :

EST.IMPAIR, EST.PAIR, ESTERR, ESTERREUR, ESTFORMULE, ESTLOGIQUE, ESTNA, ESTNONTEXTE, ESTNUM, ESTREF, ESTTEXTE, ESTVIDE, ET, OU

La liste des fonction Excel est détaillée dans l’article liste des fonctions Excel.

Par exemple :
=SI(ESTERREUR(B3);“”;100)
SI B3 renvoie une erreur ALORS rien SINON 100

=SI(ESTTEXTE(“DOPHIS”);“La valeur saisie est du texte”;“Vous n’avez pas saisi du texte”)
SI DOPHIS est du texte ALORS La valeur saisie est du texte SINON Vous n’avez pas saisi du texte

Différents exemples d’utilisation de la fonction SI Excel

Renvoyer rien avec la fonction SI

Tester avec la fonction SI, si une cellule est vide
=SI(A1=””;18;“”)
SI A1 est vide ALORS 18 SINON rien

Comparer du texte avec la fonction SI

=SI(A1=”CHAMBERY”;“SAVOIE”;“”)
SI A1 est égale à CHAMBERY ALORS SAVOIE SINON rien

Comparer des valeurs numériques avec la fonction SI

=SI(F2>=10000;“Objectif atteint”;“pas terrible”)
SI F2 est supérieure ou égale à 10 000 ALORS Objectif atteint SINON pas terrible

Fonction SI avec date en condition

=SI(B3<DATEVAL(“01/01/2000”);“Autre millénaire”;“Ce millénaire”)
SI B3 est inférieure au 01/01/200 ALORS Autre millénaire SINON Ce millénaire

La formule suivante est équivalente :
=SI(B3<DATE(2000;1;1);“Autre millénaire”;“Ce millénaire”)

Une autre solution est d’indiquer la date du 01/01/2000 dans une cellule est de faire référence à cette cellule dans la comparaison en position absolue (en utilisant les $).
=SI(B3<$C$1;“Autre millénaire”;“Ce millénaire”)

La dernière solution est la suivante :
Pour Excel, la date du 01/01/2000 correspond à la valeur 36526. Il s’agit du nombre de jours écoulés depuis le 01/01/1900 (il s’agit du moyen pour Excel de gérer les dates).
Pour trouver cette valeur, saisir la date dans une cellule et passer en format nombre.
La formule peut donc s’écrire :
=SI(B3<36526;“Autre millénaire”;“Ce millénaire”)

Les 4 formules présentées sont équivalentes et peuvent être utilisées en fonction de votre préférence.

Insérer une formule dans une fonction SI

Pour reprendre l’exemple du début d’article, et le test sur les codes de sécurité social. Il est possible d’intégrer une formule dans le test.
=SI(CNUM(GAUCHE(B3;1))=2;“Madame”;”Monsieur”)

Les Messages d’erreur rencontrés avec la fonction SI Excel

Nous avons rencontré une erreur dans cette formule

Au moment de valider la cellule ce message apparait. Cela signifie qu’il manque un élément de syntaxe pour que la formule soit juste.
=si(Test_logique; Valeur_si_vrai;Valeur_si_faux)
Il doit manquer soit une parenthèse soit un point virgule, il est possible que vous ayez une parenthèse en trop.
Concernant le nombre et la position des parenthèses, il est possible de vérifier avec Excel.
Positionner le curseur de la souris dans la barre de formule pour la cellule concernée.
Un jeu de couleur sur les parenthèses se met en place pour identifier à quelle fonction appartient telle ou telle parenthèse.

Erreur : Le résultat de la fonction SI renvoie FAUX

Une cellule avec une fonction SI qui renvoie FAUX de manière involontaire vient du fait qu’il manque un argument à la fonction. Le 3ème argument n’a pas été défini :
=SI(C3=2;”Madame”)
La formule doit être modifiée pour ajouter la valeur à renvoyer si le test logique est FAUX.

#VALEUR ! Erreur avec SI Excel

Une fonction avec une mauvaise syntaxe est utilisée à l’intérieur de la formule SI.

Fonction SI plusieurs conditions : SI imbriqués

Il est possible d’imbriquer des SI dans des SI jusqu’ à 7 fois. Cette méthode est détaillée dans SI imbriqués.
Une alternative aux SI imbriqués avec plusieurs conditions est la fonction CHOISIR.

Autres Fonctions conditionnelles

Il existe d’autres formules conditionnelles basées sur le même principe de fonctionnement. Une fois que le fonctionnement de la fonction SI d’Excel est intégrée, il est assez aisé d’utiliser les fonctions associées : SOMME.SI, NB.SI, MOYENNE.SI, SOMME.SI.ENS, NB.SI.ENS, MOYENNE.SI.ENS